logfile: certificate_unknown in processing a request


  • MOD

    Hi!,

    SInce 1-2 days i see a lot of these errors in my mycontroller logfile. It seems related to a gui loading issue i had sometime ago since no page loades correctly anymore..... See this post

    The error i see is:
    [Sun Jul 07 09:07:29 CEST 2019] IO error: javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown in processing a request from /192.168.178.14:8443 / sun.security.ssl.SSLSocketImpl

    What cound be the issue here...



  • @Tag Have you tried different browsers and cleared the cache?


  • MOD

    @skywatch
    Yep, did multiple reloads, clear cache, etc etc... no succes.

    Then I tried this evening, i connected to my server on the "external"addres of my router.. (just portforwarding into my own network) and guess what, I got a login screen, after loging on, all works like a charm....

    So my question:
    How to get a login screen , especially when you are not able to logoff?



  • @Tag Do you see any error on browser console?


  • MOD

    @jkandasa

    Hi There!,
    The only browser that did not work was my phone browser... and it just started working again after the login screen...

    Is there any url that i can connect to that gives me a login screen?
    Any clue what the eror means?.... (if usefull, this behavior started with the 1.4 final version..).



  • @Tag

    Is there any url that i can connect to that gives me a login screen?

    No, we do not have any URL for login screen. MyController is a single page(angular based) application

    Any clue what the eror means?.... (if usefull, this behavior started with the 1.4 final version..).

    Till now I do not face this kind of issue. Not able to reproduce in my environment too. So I do not have any clue 😞


  • MOD

    Slowly narrowing down the issue....
    The browser i am using is chrome on android

    Here is how i reproduce the issue:

    When I connect to the server from my own lan.. it works like a charm... the problem starts once I connect from the internet to my server.

    On my router I enabled port forwarding for port 8443 to my server, so all traffic for this port (8443) will be forwarded to the local IP of my server also on port 8443.

    At this moment it seems that besides the port forward for 8443, another port needs to be forwarded... but which one....

    Not giving up... will find the issue 🙂



  • @Tag Maybe it's the firewall on your router or an isp thing.

    Try connecting from the internet on port 443 and then forwarding that to port 8443 to the server. Worth a try to see if the issue persists?


  • MOD

    @skywatch

    No luck.... ☹

    If my android device, phone or laptop is waking up from sleep, it sometimes does not work i get the translate stuff, however
    It seems to work fine after I have used the login page...

    so what happens at the login page that make things work........
    (it must be a change after version 1.4... for me this started at 1.4 final...)



  • @Tag Pity - I was clutching at straws that maybe https was blocked on non-standard port or a firewall blocking on non-standard ports.

    Ah well, we tried.

    I am fresh out of any other suggestions as this is beyond my experience.

    Sorry 😞


  • MOD

    @skywatch
    No worries, all input is appreciated!!
    for me, worst case scenario is that I go back to 1.4 pre-final.. and wait for 2.0 😉



  • @Tag I dont use chrome but maybe you need to install the cert somehow? ??? Perhaps this is different to a url based cert? who knows? It's all I can think of at the moment 😞


  • MOD

    Progress!!!
    Did some testing and had 2 lines in Utilities --> HTML additional headers --> Scriptfiles

    https://192.168.178.50:8443/mylib/gauge.min.js
    https://217.101.85.85:8443/mylib/gauge.min.js

    Once I removed the first line and only left the last one, my GUI issues seems to be gone!



  • @Tag You may take it from public CDN. to work on both LAN and outside LAN

    or remove host details and keep path only, /mylib/gauge.min.js might work (not tested)


  • MOD

    @jkandasa

    Just using /mylib/gauge.min.js (without the https://xxx.xxx.xxx.xxx/8443) works okay too! 🙂

    So problem solved!, issue was multiple lines to the same script in Utilities --> HTML additional headers --> Scriptfiles

    Case closed


Log in to reply
 

Suggested Topics

5
Online

518
Users

427
Topics

2.6k
Posts