How to start at all



  • Hello
    I downloaded mycontroller on my RPi3 and started reading the manual but am obviously missing something fundamental here. How do I start this program? And I really need an explanation. How do the login screen materialize on my computer screen? There is obviously some sort of start.h to execute and then? Everything looks as it did before I executed this. I don't get this at all.
    Staffan


  • MOD

    Hi!,

    First of all welcome to the forum,

    Step one is to install my controller, so download the archive from here

    Then extract the archive on the rapsberry pi,

    sudo gunzip -c "filename" | tar - xvf -
    

    once extracted

    cd mycontroller/bin
    start.sh
    

    Then point your browser to the ipaddress of your pi, port 8443

    https://<PI address>:8443
    

    If you see errors during the startup of mycontroller, you might need to install a correct version of java, follow this guide

    Mycontroller is running in your webbrowser.

    I can imagine that this is a lot of information, are there any specific question you have?



  • Hello
    Thank you for your reply. The ending of your reply was a total surprise to me. That I was supposed to open the web browser and type my IP number (is it so?). Who could have guessed that? The manual takes a leap into showing a login window after writing something about installation. But I have experienced a bunch of problems.

    First he "sudo gunzip -c "filename" | tar - xvf -" command. I guess that I download the tar.gz file found in the link you propose. And then type the file name where you write "filename" (with or without extensions?). Well, it does not work. I am to add a flag of some sort. And I had four failed downloads before it managed to download all 32 MB (of topic perhaps but it added to frustration).

    Anyway, I downloaded a zip file earlier today, before writing in the forum, and managed to de-compress that into a "mycontroller" folder.

    The start.sh command did not work. I guess that I first change directory and then type start.sh. But the command is unknown according to my Pi. Well, since I had extracted something and could localize it I actually did try to just double click on the start.sh file in the raspbian file manager and at least it did not explode but there was no sign if some sort of a magic had started. So I wrote in the browser the https line and what I think is the IP adress of my Pi. This was a big no-no according to my browser. But I ingored it and arrived at the login window. And to my surprise I could log in. I can see the environment where I am supposed to work and have hope to be able to achieve something.

    And if I double clicked stop.sh I was not able to log in. And once I double clicked start.sh it worked again. But from time to time I get a bunch of security warnings in my web browser. I can ignore them and I am not overly worried about my little Pi as long as don't open Pandoras box to other parts of my home network. Am I?

    Staffan


  • MOD

    @staffan

    At least you got it running!

    if you go to the terminal window and want to start mycontroller, you need to add a ./ before the start command, so the complete command would be:

    ./start.sh
    

    Basically what you are saying with the ./ is "in the current directory execute start.sh
    (same for stop also....)

    if you point your web browser to the rapberry on the raspberry itself (i assume you use the desktop b=version on the rapberry) then you can also use the following address in your webbrowser:

    https://localhost:8443
    

    you will get an error since you are using https, and there is no valid certificate, to solve this there are 3 options:

    1. Configure mycontroller to use http (see the documentation)

    2. Setup a valid certificate as described here

    3. just accept you will get a warning.... 🙂

    Good luck with this great software!



  • No, it doesn't work to log in in the browser window. I was lucky a few times, thats all. After being fed up with MyController I tried other controller softwares for RPi and they were equally awful. Type <PIadress>:port (seems to be the preferred mode of operation) and nothing happens, "refused to connect" is all.

    I get a hint somewhere that there are issues with the newest Raspbian version, Stretch. Since one of my desperate attempts to fix it was to make a completely new installation I of course have this installed. When I had the problems I report above the OS was no more than a month old so that should have been stretch also. There are zillions of fixes proposed on various forums but I simply can't sort it out. Can anyone here?


  • MOD

    @staffan

    Well we first need to know what the exact error is before we can try and help you fix it.
    If you start mycontroller (still the best out there) and you point your browser running ON the RPI itself to:

    https://localhost:8443
    

    what is the exact error that you get? (forget about the certificate error)

    if you get the connection refused error it might be that mycontroller is not started...



  • So I am here again. It seems to be working again. Occasionally. But anyway, far better than any of the other controller I tried (not that that was much of a competition). Java is mentioned sometimes as a potential problem. I see that I have 1.8.0_65 and I think that is a current version. "Oracle" is referred to on many places but that name isn't found anywhere.

    And then I built a MySensors gateway to connect to my RPi, really no big deal since I have been fiddling with Arduino for several years and happened to have both a Nano and a RF24 lying around. I wired things up and downloaded the sketch.

    So I want to connect my gateway, plug it into the USB I guess, and then add it in MyController (and then add sensors that I am about to build). It is supposed to be detected automatically I think but it isn't. There isn't that nice little "actions" button. So I can click on "add gateway" beside the non existing "actions" button and now I get a multitude of choices of which I have no clue.

    Enabled: Ticked by default. Seems like a good idea to enable things
    Gateway name: ? I looked into the sketch if there is any variable or something. No clue
    Tx message...: No clue. The pre selected 0 might do
    Network type: MySensors
    Type: Serial
    Driver: ?
    Port Name: ?
    Baud rate: ?
    Retry freq...: ?

    So there I am. Going to bed again. My wife had a decent conversation with me on Saturday she says. But who am I to give up. I want to monitor the moisture level in my bathroom but starts to think that buying a small instrument with display and go into the bathroom and read it is far more efficient way.

    Staffan


  • ADMIN

    @staffan Hi, Did you check the user manual file? available on download section?

    If your MySensors gateway is USB, select as follows,
    0_1508474313121_0d214ad7-684c-4384-86b0-053807ee98b3-image.png

    Tx message processing delay: Transmission delay between on each message from MyController to this gateway to avoid the collision on MySensors network.
    Driver: Keep it as Auto
    Port name: default /dev/ttyUSB0
    Baud rate: default 115200
    Retry frequency: For some reason, if your gateway goes down. MyController attempt to reconnect every X seconds once.

    • Connect your gateway on RPI USB port, run this command to know your USB port name: ls -lh /dev/ttyUSB*
    • Once you setup the gateway on MyController, your gateway should show UP.
    • now click on Action button on gateway and select Discover, [Note: You should have added about your node data on presentation() block of your node code.]
      0_1508475338692_f531a78d-46ca-4c88-8698-38bd375eecd3-image.png.

    Now you can see your gateway and nodes on MyController.


 

Suggested Topics

8
Online

363
Users

350
Topics

2.1k
Posts