• Hello,
    I tried to update my devices firmware , i miss something ? (Probably yes ...)

    I created a firmware . with bin file from Arduino compiler :
    0_1488020518584_Capture d’écran_2017-02-25_11-59-34.png

    Then i asked to my device to be updated :

    0_1488020605682_Capture d’écran_2017-02-25_12-03-11.png

    "Modifier un firmware" - > update firmware

    Reel text in french should be "Mettre à jour le firmware" , (more comprehensiv)

    Ok, then , what should be happening ?


  • @Stephan35 Enable DEBUG on your node and check it on serial port and Status >> Resources logs on MyController.

  • Hello,
    Here is some news :

    Really nothing append when i ask to update firmware.

    /* User configurable variables */
    /* ***************************************************************************** */
    // Enable DEBUG in sketch to show debug prints.
    #define ENABLE_ERROR
    #define ENABLE_INFO
    #define ENABLE_DEBUG
    //#define ENABLE_TRACE

    Resources logs :

    2017-03-02 21:47:31,788 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:166] Application information: [Version:0.0.3.Final-SNAPSHOT, Database(type:H2 database embedded, version:1.4.193 (2016-10-31), schema version:1.03.05 - 2016 Nov 18), Built on:2017-02-22T13:38:19+0100, Git commit:8dd52693413b8a9cc6196bd77203ac69f4852ea3:development]
    2017-03-02 21:47:31,830 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:191] Reload DAO triggered...
    2017-03-02 21:47:33,536 INFO [Thread-6] [org.mycontroller.standalone.message.RawMessageQueue:54] Cleared offline messages[0] from the queue.
    2017-03-02 21:47:34,436 INFO [main] [org.mycontroller.standalone.gateway.mqtt.MqttGatewayImpl:67] MQTT Gateway[name:MQTT for ESP8266, URI:tcp://localhost:1883, NetworkType:MyController] connected successfully..
    2017-03-02 21:47:42,663 INFO [main] [org.mycontroller.standalone.StartApp:211] TJWS server started successfully, HTTPS Enabled?:true, HTTP(S) Port: [8443]
    2017-03-02 21:47:42,721 ERROR [main] [org.mycontroller.standalone.mdns.McmDNSFactory:116] Unable to create mDNS registry service
    2017-03-02 21:47:42,728 INFO [main] [org.mycontroller.standalone.StartApp:109] MyController.org server started in [40721] ms

    Do i miss something ? (again ?)

    Best regards

  • @Stephan35 This is not resource log!

    You can check resources log on GUI. Status >> Resources log also do check on ESP serial port.

  • Hello,

    I've got exactly the same issue : nothing happen when uploading a firmware.



    No output on serial port neither on Logs.

    Any idea ?

  • @Emmanuel
    Sorry, I have not looked at this problem since the last time.

  • @Emmanuel did you change MQTT_MAX_PACKET_SIZE to 512 bytes on PubSubClient.h

  • @jkandasa Yes, I've got #define MQTT_MAX_PACKET_SIZE 512

  • OK, my mistake there. The Node // Firmware Name was empty. (It has been discarded when node has been deleted)


    Now it works like a charm.
    Thanks for you attention.

Suggested Topics