Ghost Nodes (Eeeek!).



  • @jkandasa

    You will be happy to know that this issue is now SOLVED! 🙂

    Since installing the latest SNAPSHOT 1.4.0, all the problems associated with this have gone away.

    Thanks for all the contuning support and excellent work.



  • @skywatch And now it's all back again 😞



  • @skywatch It is so sad to hear this again 😞
    Can you try with USB to TTL, when you receive your order?



  • @jkandasa Of course I can. But still I am not getting to the root cause of this issue and it is very annoying!



  • @skywatch SOLVED - FINALLY! 🙂

    See post here... https://forum.mycontroller.org/topic/328/serial-problem/57

    It is a problem with the way Rpi3Bserial port works.They changed it (and broke it).



  • @skywatch Oh Nooooooo - Not again!

    This morning I find a new ghost node (70) has registered.
    0_1541410427529_ghost70.jpg

    I will implement the logging asap and post details if/when it happens again.



  • @skywatch It is bad 😞
    if it happens very often. I can write a script for you to delete node's not in the predefined list.



  • @jkandasa Following a period of relative calm in my setup, yesterday I got 2 ghost nodes appear again. One was a single temperature reading (which if correct was from the heating boiler) and the second was a single on/off.

    I wonder if there is some way that a malformed message could do this? The temp one showed +58.4C and the only thing to get that hot is the heating system.

    I have some nice new power supplies now (not from ali or ebay!) and will be building a UPS with these to improve stability and performance during power black/brown outs.

    So nothing to do on myc front unless this still happens after all the above is done. The new supplies have cured issues on other pi builds, so hopeful on this one too.... 😉



  • @skywatch I don't know if this is your case, but I got similar situations when I used MySBootloader. When I flash the bootloader on a new Arduino, the first time it connects to the networks without a sketch it appears as an ID 1, which I guess is a default if nothing is written in the EEPROM.
    Could this explain your issue?
    Daniele



  • @Daniele Thanks for sharing your knowledge.

    I still use the bootloader that is installed in China, so not the issue for me. I also specify node ID in the sketch to avoid issues with getting it assigned from the GW.

    I have had a much better experience lately with new quality power supply, but still had a weird crash this week.

    I woke to find the pi running, activity light flashing as it normally does, but no web page served, no ssh access and no activity light on the SSD.

    Within a few days I will re-build removing as many dupont connectors as I can and soldering wires instead. It's really the last thing I can think of, but I am seeing things improve which is a good thing! 😉


Log in to reply
 

Suggested Topics

5
Online

511
Users

424
Topics

2.6k
Posts