• Twice in the last month I have seen 'Ghost' nodes appearing.

    These 'ghost' nodes seem to happen overnight and can even have a 'ghost sensor' attached to them.

    Of course, I know that they are not real and simply delete them. But a non-existent node and sensor register with the controller? How does this happen?

  • @skywatch You might have a problem with hardware, serial port driver or MyController serial parsing.

    Do you see any ERROR or WARN in mycontroller.log related to your ghost nodes? can you check the log?

  • @jkandasa Thanks, there is nothing in the server log relating to the creation of the nodes. I usually find them in the topo or resource view.

  • @skywatch I hope it should be a hardware issue(maybe with cheap Chinese clones).
    Can you add MY_NODE_ID in the sketch?

  • @jkandasa Thanks ...

    All nodes already have a MY_NODE_ID allocated to them (As well as #define MY_PARENT_NODE_ID 0 & #define MY_PARENT_NODE_IS_STATIC. That way I am sure what is where and can have a logical numbering system.

    I have tried 3 different SD cards and now don't use any sd cards at all as it all boots and runs from a Kingston A400 SSD (120Gb) via usb.
    I have tried different cables and power supplies, added multiple capacitors and ferrite beads.
    I am on the 4th pro mini module as the GW. All of them had no problems when attached to the PC, so assume it is not the issue, but I could be wrong!
    I have tried at least 5 radio modules (all with caps) and currently using the mysensors recommended EBYTE modules. I don't really have an issue with them.
    I've tried a pi 2 and 2x pi 3's.
    I could try again with a 5V pro mini as I recently got a shipment of level converters, so that's the last thing I can think of....

    Things are getting better slowly. I still get occasional corrupted packets, but only a few a day now, that and the ghost nodes. Otherwise it's not too bad.

  • @skywatch Seems I have to set up a serial gateway to reproduce this issue.

    Are you using USBtoSerial or direct TxRx of RPI?

  • @jkandasa Direct using short (60mm) cables, tx/rx from pro mini to tx/rx on rpi.

    GW is using a 3.3v 8MHz pro mini to eliminate the need for level shifter. 38400 baud rate (have tried 19200 and 9600 as well in the past).

    As I said before please do not use your time on this. Lets see how it goes with the 'new' mycontroller when it is released and if it is still a problem at that point then maybe it's worth a look.

    I guess not many people are running their set up like mine.

  • @skywatch

    I awoke this morning and checked in with myc resources, this is what I find.....
    All the 'red' nodes are ghosts that do not exist in real life.....


  • @jkandasa Thank you once again! 😉

    I totally removed arduino ide from the laptop and reinstalled only the latest version (1.8.7). Then I took the GW apart and recrimped some of the dupont connectors (some Chinese ones are poor quality). I reflashed the GW skecth (clearing eeprom first) and reconnected it all back up. Since doing this, no ghost nodes have appeared in the last 20 hours!....

    Maybe they have all left for Halloween ? 😉

  • @jkandasa

    You will be happy to know that this issue is now SOLVED! 🙂

    Since installing the latest SNAPSHOT 1.4.0, all the problems associated with this have gone away.

    Thanks for all the contuning support and excellent work.

  • @skywatch And now it's all back again 😞

  • @skywatch It is so sad to hear this again 😞
    Can you try with USB to TTL, when you receive your order?

  • @jkandasa Of course I can. But still I am not getting to the root cause of this issue and it is very annoying!

  • @skywatch SOLVED - FINALLY! 🙂

    See post here... https://forum.mycontroller.org/topic/328/serial-problem/57

    It is a problem with the way Rpi3Bserial port works.They changed it (and broke it).

  • @skywatch Oh Nooooooo - Not again!

    This morning I find a new ghost node (70) has registered.

    I will implement the logging asap and post details if/when it happens again.

  • @skywatch It is bad 😞
    if it happens very often. I can write a script for you to delete node's not in the predefined list.

  • @jkandasa Following a period of relative calm in my setup, yesterday I got 2 ghost nodes appear again. One was a single temperature reading (which if correct was from the heating boiler) and the second was a single on/off.

    I wonder if there is some way that a malformed message could do this? The temp one showed +58.4C and the only thing to get that hot is the heating system.

    I have some nice new power supplies now (not from ali or ebay!) and will be building a UPS with these to improve stability and performance during power black/brown outs.

    So nothing to do on myc front unless this still happens after all the above is done. The new supplies have cured issues on other pi builds, so hopeful on this one too.... 😉

  • @skywatch I don't know if this is your case, but I got similar situations when I used MySBootloader. When I flash the bootloader on a new Arduino, the first time it connects to the networks without a sketch it appears as an ID 1, which I guess is a default if nothing is written in the EEPROM.
    Could this explain your issue?

  • @Daniele Thanks for sharing your knowledge.

    I still use the bootloader that is installed in China, so not the issue for me. I also specify node ID in the sketch to avoid issues with getting it assigned from the GW.

    I have had a much better experience lately with new quality power supply, but still had a weird crash this week.

    I woke to find the pi running, activity light flashing as it normally does, but no web page served, no ssh access and no activity light on the SSD.

    Within a few days I will re-build removing as many dupont connectors as I can and soldering wires instead. It's really the last thing I can think of, but I am seeing things improve which is a good thing! 😉

Suggested Topics