Graphical widgets loading forever



  • Hi,
    I just installed MyController on a raspberry pi 3. While adding standard sensor widgets to a dashboard works fine, all of the graphical widgets keep loading forever.
    Any ideas what may be wrong ?
    Stefaan


  • ADMIN

    @stefaanv Do you see any errors on log file (mycontroller/log/mycontroller.log) or in browser console?



  • [SOLVED]

    @jkandasa I don't get any graphical content at all, neither widgets nor under resources->sensors.

    Log stays empty as well, maybe increase the loggerlevel? But I don't know which one:

    2016-08-05 13:05:49,145 INFO [main] [org.mycontroller.standalone.StartApp:209] TJWS server started successfully, HTTPS Enabled?:true, HTTP(S) Port: [8443]
    2016-08-05 13:05:49,146 INFO [main] [org.mycontroller.standalone.StartApp:107] MyController.org server started in [20661] ms
    [Fri Aug 05 13:05:55 CEST 2016] IO error: javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection? in processing a request from /192.168.178.34:8443 / sun.security.ssl.SSLSocketImpl
    2016-08-05 13:07:46,362 INFO [Acme.Utils.ThreadPool(1)-PooledThread: Acme.Serve.Serve$ServeConnection@14b40fc] [org.mycontroller.standalone.gateway.mqtt.MqttGatewayImpl:70] MQTT Gateway[tcp://localhost:1883] connected successfully..
    2016-08-05 13:15:17,765 INFO [Acme.Utils.ThreadPool(6)-PooledThread: Acme.Serve.Serve$ServeConnection@293a6b] [org.mycontroller.standalone.mqttbroker.MoquetteMqttBroker:71] MQTT broker restart triggered...
    2016-08-05 13:19:24,743 INFO [Acme.Utils.ThreadPool(6)-PooledThread: Acme.Serve.Serve$ServeConnection@62c4af] [org.mycontroller.standalone.gateway.mqtt.MqttGatewayImpl:70] MQTT Gateway[tcp://localhost:1883] connected successfully..
    

    PS: This only affects the "Variables graphical view". Other graphical widgets are working fine. This issues affects dashboard and sensor-detail view stuff.

    Well I found the solution .. blocked by "ublock origin"



  • @stefaanv https://github.com/mycontroller-org/mycontroller/issues/236#issuecomment-238017945

    Have a look if your adblocker is interfering. Press F12 in your browser and look at the "console"-output.

    An example of adblocker interfering:

    0_1470481819199_upload-c774db81-e0d5-48d7-abc7-98a05c8d3a94

    This can be solved by whitelisting the mycontroller.org site.


Log in to reply
 

8
Online

439
Users

231
Topics

1378
Posts

Looks like your connection to MYCONTROLLER.ORG was lost, please wait while we try to reconnect.