New Build not working..... 1.3.0



  • So my old myc went bad (sd card failed) and took with it all my settings and backups (lesson in there).

    Now I have new sd card with latest java and myc 1.3.0 and can't get any data from the nodes. All nodes worked prior to this.

    Set up is with arduino pro-mini as gateway connected to nrf24l01+ (tried another one and still same results). Internal from mcagent is working fine. But even with auto register and rebooting nodes (in one case even erasing eeprom and reprogramming the node) it still has problems.

    The gateway connects to myc and I have tried 'auto' and 'Jserial' etc, all with same results.

    Have I missed something? Can I tail the gateway somehow? sudo tail -f /dev/serial0 doesn't produce anything.

    Ideas/suggestions welcome!



  • Just a quick update ....

    I have removed the promini and nrf24l01+ from the pi and connected to the laptop. They both work fine and I can see messages from other nodes.

    MYC connects serially with the gateway at 38400 (for 3.3v 8MHz module) but still no data.

    Connecting a node to the pc and looking at the serail monitor I see it fails to find a parent.....Yet radios, nodes and gateway all appear to be working.

    Could it be something simple? I can't think what to try next.


  • ADMIN

    @skywatch I guess you are using RPI serial port. As you have formatted your RPI. I guess serial port will be used as a console of RPI. You have to disable console.


  • MOD

    @skywatch

    Hi there sir!,
    jkandasa is right, most probably a getty is running on your serial port device...

    See this link on how to disable it

    Another tip I got for you, to move to and USB connected SSD, i bought one in china of 32GB and hooked it up to and USB port in an USB2SATA enclosure. I only use the SD card these days to boot the kernel and after that root is chrooted to the SSD card. Works like a charm.
    See rpi-clone also works on the OPI-zero running armbian 😉

    update:
    Posted the steps I took to get the system to boot from the SSD here


 

8
Online

2.3k
Users

303
Topics

1.8k
Posts

Looks like your connection to MYCONTROLLER.ORG was lost, please wait while we try to reconnect.