automatic backup



  • I set up the automatic backup in this way:
    ![alt text](0_1513841434758_f6bc71f5-911e-4e6b-bda2-cb5858489ca9-image.png
    but when I look in the folder, I can find only the on-demand backups I did.
    The folder is an usb stick, mounted automatically through fstab.

    I don't understand what's going wrong...
    The mount is working fine, since I can do on-demand backups.

    Daniele



  • @daniele As you have mentioned 1 days, it needs 24 hours to perform its first backup. You may do an hourly backup with 5~10 retention files might be enough. When you configure hourly backup, you may lose only hour data, if something goes wrong.



  • I forgot to mention that's one week I set it up this way



  • @daniele Do you see any error in the log file? mycontroller/logs/mycontroller.log



  • I can find many errors of this kind:

    [Wed Dec 20 22:25:35 CET 2017] IO error: java.net.SocketException: Connection reset in processing a request from /192.168.1.165:8443 / sun.security.ssl.SSLSocketImpl
    [Wed Dec 20 23:17:03 CET 2017] IO error: javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown in processi
    ng a request from /192.168.1.164:8443 / sun.security.ssl.SSLSocketImpl
    

    I'm not an expert programmer, but they don't seem to be related to my issue with automatic backup.



  • @daniele Without debug log it is tough to root cause this issue. Could you please do the followings on your MyController server to get debug logs?

    Enable debug log message for the followings on mycontroller/conf/logback.xml,

      <logger level="DEBUG" name="org.mycontroller.standalone.backup" />
      <logger level="DEBUG" name="org.mycontroller.standalone.scheduler" />
      <logger level="DEBUG" name="org.mycontroller.standalone.timer" />
    

    NOTE: MyController server restart is required to apply this change.
    To stop: mycontroller/bin/stop.sh
    To start: mycontroller/bin/start.sh

    After this change, modify your backup settings to take backup in one minute. Now check logs on mycontroller/logs/mycontroller.log

    0_1513862661016_Screenshot from 2017-12-21 17-49-54.png



  • The odd thing is that yesterday I tried with 5 minutes, and it worked.
    Then I moved to 12 hours, and the backup has never been created.

    I activated the debug logs you suggested, tried again with 1 minute and 1 hour, and everything worked perfectly.
    Now I moved again to one day, I'll let you know the result.



  • @daniele Great! Seems we might have an issue with 12 hours or more. let me check it.



  • After 1 day with debug enabled I can't see any other error, but still no backup.
    Now I tried to set it up every 10 hours, I'll let you know the result.



  • Same result with 10 hours, while I got a successful backup with 8 hours.





  • @daniele I have update scheduler library. I do not see this issue now. Also, I have added an option to show next execution time. Kindly check it in SNAPSHOT version and let me know.

    Thank you!

    0_1518324492744_b1071f89-22c0-4126-ba1a-09ad60ca68c2-image.png



  • Yesterday evening at 10 PM I changed the schedule from "every 8 hours" to "every 1 day", to check the change you did.
    This evening I'll check the result, but what I notice in the meantime is that there's something wrong in the label showing the next execution:

    0_1518509051050_64ef58ba-47e8-43ea-9ea0-1ea1c9fed471-image.png



  • @daniele Thank you! Can you check the Uptime on your MyController server?

    0_1518538194415_d4f4f6a3-d927-461c-8b4b-87311f2e615b-image.png



  • This is the uptime of my server:

    0_1518539526668_404d31c9-c662-4abf-8c77-12030b111259-image.png

    To simplify your analysis: 4 AM is the time I daily restart my Raspberry.



  • @daniele

    To simplify your analysis: 4 AM is the time I daily restart my Raspberry.

    That's the root cause. MyController backup job not following cron or regular time. It is following repeat time from the scheduled time. When you restart the server this timer also gets restarted. For your setup, you can configure a maximum of 23 hours and 59 minutes if you configure it exactly at startup.

    So if you configure backup every > 12 hours and < 24 hours, you should get daily backup from next day.



  • Now that's clear, I'll try using 23 hours.
    Thanks!



  • I can confirm that with 23 hours the scheduler works perfectly now!
    Thanks a lot!


Log in to reply
 

Suggested Topics

1
Online

463
Users

400
Topics

2.5k
Posts