Email notification setup


  • MOD

    Hi!,

    Are you able to "ping" the server from the command line?

    You should see the output like below

    # ping smtp.gmail.com
    PING gmail-smtp-msa.l.google.com (108.177.126.108) 56(84) bytes of data.
    64 bytes from 108.177.126.108: icmp_seq=1 ttl=44 time=13.4 ms
    64 bytes from 108.177.126.108: icmp_seq=2 ttl=44 time=15.7 ms
    64 bytes from 108.177.126.108: icmp_seq=3 ttl=44 time=104 ms
    64 bytes from 108.177.126.108: icmp_seq=4 ttl=44 time=73.2 ms
    64 bytes from 108.177.126.108: icmp_seq=5 ttl=44 time=41.1 ms
    64 bytes from 108.177.126.108: icmp_seq=6 ttl=44 time=37.7 ms
    64 bytes from 108.177.126.108: icmp_seq=7 ttl=44 time=50.8 ms
    ^C
    --- gmail-smtp-msa.l.google.com ping statistics ---
    7 packets transmitted, 7 received, 0% packet loss, time 6009ms
    rtt min/avg/max/mdev = 13.407/48.175/104.992/29.960 ms
    

    Can you check if there are no spaces in the servername field in mycontroller itself?

    Port 587 is the TLS port, try to disable SSL and use port 25
    does that work?



  • Yes, seems I am able to ping the server:

    0_1513101041832_cdc7c1e2-1e03-4a36-9eeb-bcef4f06a973-image.png


  • MOD

    @iahim67

    okay that is good so we know we can at least connect to the server.

    How about disable SSL and use port 25? does that work?



  • same error:

    0_1513105749868_0f6389df-9cb8-469e-a5f2-88fc8b293db8-image.png



  • One more thing to note, perhaps it helps: I am using Domoticz in parallel and I can send email notifications from Domoticz, the following does work:

    0_1513105918431_a7102aee-7238-4394-8647-10ff7508c126-image.png



  • @iahim67 can you investigate on network response?

    right click on MyController page, select Inspect also check mycontrollor.log is there any error?

    0_1513132151180_email-status.png



  • I get this:

    0_1513182040082_0e4c9ea9-9e7f-4865-984c-fbeb63f9def9-image.png



  • Did this get resolved? I am having the same issue now.



  • @skywatch I do not see any issue with email setup. Are you getting 400? can you post mycontroller.log when you perform this action?



  • @jkandasa THanks - The pi mycontroller is running on has ssmtp installed and this works for sending cron messages etc.
    I tried to ping my isp mail server with no response (but also got no response from a win10 machine either) yet mails are working as far as I can tell.
    I have to get Mum from the hospital now so will try again later when I have time.



  • @skywatch Emails working fine for me now 🙂


Log in to reply
 

Suggested Topics

6
Online

560
Users

454
Topics

2.8k
Posts