How to display pi properties?



  • Hi,

    I would like to add the following to the main dashboard......

    Pi CPU temperature, core loading for all cores and free memory.
    How can add these to graph the data please?


  • ADMIN



  • Thanks for the response.

    There don't seem to be any instructions with that download? Even the readme file is useless for installing. Still, I copied the folder and removed "-rpi-master" and tried to start it with start.sh. It just complains about a missing log file. I tried to creat the log file but still no joy. So, how about a short tutorial on how to use it, then you might get more feedback about it! 🙂


  • MOD

    @skywatch

    The logfile should be automagically created, is the directory that stores the logfile writable?

    root@orangepizero:~/mcagent# ls -la
    total 24
    drwxr-xr-x  6 root   root   4096 Mar  5 14:54 .
    drwx------ 25 root   root   4096 Jun 26 17:00 ..
    drwxrw-r--  3 user user 4096 Jun 26 16:58 bin
    drwxrw-r--  2 user user 4096 Jun 26 17:00 conf
    drwxr-xr-x  2 root   root   4096 Jun 26 16:57 lib
    drwxrw-r--  2 user user 4096 Jun 26 16:58 logs
    

    you should see something like the above.



  • Hmmm....no it does not look the same. Does the following help?

    pi@HAAS:~/mcagent $ ls -la
    total 32
    drwxr-xr-x 4 pi pi 4096 Jul 4 18:42 .
    drwxr-xr-x 18 pi pi 4096 Jul 4 18:18 ..
    drwxr-xr-x 2 pi pi 4096 Jul 4 18:43 logs
    -rw-r--r-- 1 pi pi 6426 Jul 4 18:16 pom.xml
    -rw-r--r-- 1 pi pi 298 Jul 4 18:16 README.adoc
    drwxr-xr-x 3 pi pi 4096 Jul 4 18:17 src
    -rw-r--r-- 1 pi pi 110 Jul 4 18:16 .travis.yml
    pi@HAAS:~/mcagent $ sudo bash /home/pi/mcagent/src/main/package/bin/start.sh
    /usr/bin/java
    java version: 1.8.0_65
    Start service issued for McAgent
    /home/pi/mcagent/src/main/package/bin/start.sh: line 54: ../logs/mcagent.log: No such file or directory
    pi@HAAS:~/mcagent $ cd /logs
    -bash: cd: /logs: No such file or directory
    pi@HAAS:~/mcagent $ cd /home/pi/mcagent/logs
    pi@HAAS:~/mcagent/logs $ ls
    mcagent.log
    pi@HAAS:~/mcagent/logs $


  • MOD

    @skywatch

    Ah, you downloaded the github version...
    See if the version that is located here.. works better.



  • Yup! 😉 That one seems to run.

    Now what should I do? ? Are there any example or scripts available? How to display cpu temp? I even restarted mycserver, but can't figure out what to do next! Doh!


  • MOD

    @skywatch
    cool!,
    not a clue, i am using the orangepi, and mcagent does not work for me (yet).....

    look into the conf directory the config files might give a clue

    or look in this topic

    once i am able to test i will post my findings here!



  • No joy yet.....the log file is full of this message.....

    2017-07-05 11:26:29,952 ERROR [Thread-4] [org.mycontroller.agent.rpi.mqtt.RpiMqttClient:82] Unable to connect with MQTT broker [tcp://localhost:1883], Reason Code: 4,
    org.eclipse.paho.client.mqttv3.MqttSecurityException: Bad user name or password
    at org.eclipse.paho.client.mqttv3.internal.ExceptionHelper.createMqttException(ExceptionHelper.java:28)
    at org.eclipse.paho.client.mqttv3.internal.ClientState.notifyReceivedAck(ClientState.java:990)
    at org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:118)
    at java.lang.Thread.run(Thread.java:745)
    

    I do not need mqtt so does it have to be enabled for mcagent to work? I even allowed annonymous login in mqtt settings and still no rpi-internal appears! ??? - How do I add the internal node? A nice feature would be a 'scan for new nodes' button - not sure how feasible that would be though! 😉


  • ADMIN



  • "MyController" is not available as a network type in the gateway update page. ?


  • ADMIN



  • Hoorah !!!! - It is working now !!!! 🙂 🙂 🙂

    Thank you so much for your kind support and time today. Whilst I have only been running this for a week or so I have learnt a lot in the process. But don't worry, I will soon be back with more questions! 😉


 

Suggested Topics

5
Online

363
Users

348
Topics

2.1k
Posts