Timers and scripts



  • Grabed the new distro. Worked a treat. Thanks for your assistance.



  • @gouds said:

    also found a small bug on the timer. (I will log this on the issues register)

    Timer issue has been fixed. you can take latest SNAPSHOT build.

    https://github.com/mycontroller-org/mycontroller/issues/270

    Gouds created this issue in mycontroller-org/mycontroller

    closed Timers - Timer Time #270



  • Cheers. Ill give this a go.



  • Hi, thanks for your post and example jkandasa,

    I'm getting the following error:

    "Cannot cast org.mycontroller.standalone.db.tables.SensorVariable to org.mycontroller.standalone.api.jaxrs.json.SensorVariableJson"

    ideas?



  • So I updated to 0.0.3.Final you posted. I stopped getting the error about the casting, but now none of my nodes register. Tried rebuilding from scratch re-adding the gateway and allowing it to auto discover. The gateway shows up and is responding but none of the sensor nodes register.

    Tried rebooting the nodes, nothing

    Tried re-flashing the firmware on the nodes, nothing.

    When I go back to 0.0.3-Alpha2 the nodes register and all works but I'm then stuck again with the casting error.

    ideas?

    I feel like its a registration issue, like the nodes are expecting a certain version of controller, but if that's the case how do I resolve that?

    Thanks again.



  • @imedia There is no version control between MyController versions. Did you see any error logs on mycontroller/log/mycontroller.log? I have introduced register node option recently, just check Register nodes automatically is enabled on Settings >> System >> MyController >> Register nodes automatically.



  • OK,

    In the logs on the FINAL version I seem to be getting this error repeatedly:

    ERROR [pi4j-single-executor-0] [org.mycontroller.standalone.gateway.serialport.SerialDataListenerPi4j:79] Exception,

    However, in Resources > Gateways the Gateway shows as connected, and in Resources > Nodes the gateway shows as seen a few seconds ago

    So it looks like the gateway is talking... I also noticed this:

    ERROR [Thread-5] [org.mycontroller.standalone.provider.mysensors.MySensorsProviderBridge:60] Unable to process this rawMessage:RawMessage(gatewayId=1, data==3,pt=0,l=0,sg=0:, subData=null, isTxMessage=false, networkType=MY_SENSORS, timestamp=1478210691023)
    org.mycontroller.standalone.message.RawMessageException: Unknown message format:[=3,pt=0,l=0,sg=0:]
    	at org.mycontroller.standalone.provider.mysensors.MySensorsRawMessage.updateSerialMessage(MySensorsRawMessage.java:139)
    	at org.mycontroller.standalone.provider.mysensors.MySensorsRawMessage.<init>(MySensorsRawMessage.java:68)
    	at org.mycontroller.standalone.provider.mysensors.MySensorsProviderBridge.executeRawMessage(MySensorsProviderBridge.java:58)
    	at org.mycontroller.standalone.message.McMessageUtils.sendToProviderBridge(McMessageUtils.java:562)
    	at org.mycontroller.standalone.message.MessageMonitorThread.processRawMessage(MessageMonitorThread.java:112)
    	at org.mycontroller.standalone.message.MessageMonitorThread.run(MessageMonitorThread.java:191)
    	at java.lang.Thread.run(Thread.java:745)
    

    If I change nothing and roll back to Alpha2 everything works fine.



  • @imedia Looks like we have issue with pi4j serial driver. Can you please change your gateway driver from auto to JSerialComm and check?



  • That seems to have done the trick thank you!

    Do you think this is a bug or is it specific to my environment? Can I provide anything to you that will help with a resolution if it is a bug?



  • @imedia I guess it should be a bug with recent pi4j driver. Let me setup serial gateway locally and narrow down the issue. Thank you so much for your support!


Log in to reply
 

Suggested Topics

0
Online

584
Users

470
Topics

2.9k
Posts