[SOLVED] 2x RF gateways always fails on reboot.



  • I recently added a second gateway to separate general sensors from security sensors. Now they are different RF channels.
    The problem is that upon a reboot of my pi neither of them seems to pass any daya to the controller. I have to pull the power on the pi and restart it with just ONE rf gateway connected. Then, after 30 seconds I reconnect the second gateway and all is working fine.
    Both RF gateways are on serial to usb boards and it puzzles me as to why this is a problem. Is it due to both wanting memory or cpu at the same time? Voltage sag when both start at once? Or something else entirely? I'll sleep on it and see......

    For now, here is the server log with a boot with both RF GW and another with one RF GW, then the second added after a short while.....

    2020-02-23 19:33:17,827 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:116] Checking migration...
    2020-02-23 19:33:26,630 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:167] Application information: [Version:1.5.0, Database(type:H2 database embedded, version:1.4.194 (2017-03-10), schema version:1.04.06 - 2018 Dec 04), Built on:2019-12-11T11:29:51+0530, Git commit:b4e9a0cc5e911acb0053e27579eb6c7b9850b76c:master]
    2020-02-23 19:33:27,322 INFO [main] [org.mycontroller.standalone.offheap.OffHeapFactory:95] Cleared McPersistent location[../conf/persistent_stores/mc/]
    2020-02-23 19:33:27,323 INFO [main] [org.mycontroller.standalone.AppProperties:530] Created directory location: [/home/mycontroller/conf/persistent_stores/mc]
    2020-02-23 19:33:28,283 WARN [main] [io.moquette.persistence.mapdb.MapDBPersistentStore:78] Using fresh MapDB store file. Path=../conf/persistent_stores/moquette/moquette_store.mapdb
    2020-02-23 19:33:28,662 WARN [main] [io.moquette.server.Server:186] Using default SSL context creator
    2020-02-23 19:33:29,387 WARN [main] [io.netty.bootstrap.ServerBootstrap:146] Unknown channel option 'TCP_NODELAY' for channel '[id: 0x8057e12c]'
    2020-02-23 19:33:29,480 WARN [main] [io.netty.bootstrap.ServerBootstrap:146] Unknown channel option 'TCP_NODELAY' for channel '[id: 0x903a66e7]'
    2020-02-23 19:33:29,491 INFO [main] [org.mycontroller.standalone.mqttbroker.MoquetteMqttBroker:54] MQTT Broker started successfully. MqttBrokerSettings(enabled=true, sslEnabled=false, bindAddress=0.0.0.0, mqttPort=1883, mqttsPort=8883, websocketPort=7080, allowAnonymous=true, enabledOnBackend=true, sslKeystoreFile=null)
    2020-02-23 19:33:30,544 INFO [mc-th-pool-1] [org.mycontroller.standalone.gateway.mqtt.MQTTDriver:94] MQTT Gateway[name:Raspberry Pi, URI:tcp://localhost:1883, NetworkType:MyController] connected successfully..
    2020-02-23 19:33:30,587 INFO [main] [org.mycontroller.standalone.scheduler.SchedulerUtils:90] System jobs reloaded.
    2020-02-23 19:33:33,164 INFO [main] [org.mycontroller.standalone.StartApp:242] TJWS server started successfully, HTTPS Enabled?:true, HTTP(S) Port: [8443]
    2020-02-23 19:33:33,231 ERROR [Thread-9] [org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm:201] Exception, RawMessage:[aF-Q~Wï¿¿ï¿°ï¿£k↑Wï¿°브zタᄌcb↑�テ£ï¿ ï¿©ï¾˜ï¿£ï¿¡ï¿ ï¿©ï¿¸	a ̄タï¿£]
    org.mycontroller.standalone.exceptions.MessageParserException: Unknown message format:[aF-Q~Wï¿¿ï¿°ï¿£k↑Wï¿°브zタᄌcb↑�テ£ï¿ ï¿©ï¾˜ï¿£ï¿¡ï¿ ï¿©ï¿¸	a ̄タï¿£], gatewayId:5
    	at org.mycontroller.standalone.provider.mysensors.MessageParserAbstract.update(MessageParserAbstract.java:120)
    	at org.mycontroller.standalone.provider.mysensors.MessageParserSerial.getMessage(MessageParserSerial.java:32)
    	at org.mycontroller.standalone.provider.mysensors.MessageParserSerial.getMessage(MessageParserSerial.java:28)
    	at org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm.serialEvent(SerialDriverJSerialComm.java:170)
    	at com.fazecast.jSerialComm.SerialPort$SerialPortEventListener.waitForSerialEvent(SerialPort.java:937)
    	at com.fazecast.jSerialComm.SerialPort$SerialPortEventListener$1.run(SerialPort.java:885)
    	at java.lang.Thread.run(Thread.java:748)
    2020-02-23 19:33:33,843 INFO [main] [org.mycontroller.standalone.api.GoogleAnalyticsApi:94] Google analytics details[enabled:false, ga_anonymous_id:0904c9fb-6a3c-4c67-9ca8-908c0c2cb2f0]
    2020-02-23 19:33:33,844 INFO [main] [org.mycontroller.standalone.StartApp:139] MyController.org server started in [16494] ms
    2020-02-23 19:39:48,320 ERROR [Thread-9] [org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm:201] Exception, RawMessage:[|\ï¿¿{ï¿¢X
    
    2020-02-23 19:33:16,596 INFO [main] [org.mycontroller.standalone.StartApp:104] 
    
    2020-02-23 19:33:17,827 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:116] Checking migration...
    2020-02-23 19:33:26,630 INFO [main] [org.mycontroller.standalone.db.DataBaseUtils:167] Application information: [Version:1.5.0, Database(type:H2 database embedded, version:1.4.194 (2017-03-10), schema version:1.04.06 - 2018 Dec 04), Built on:2019-12-11T11:29:51+0530, Git commit:b4e9a0cc5e911acb0053e27579eb6c7b9850b76c:master]
    2020-02-23 19:33:27,322 INFO [main] [org.mycontroller.standalone.offheap.OffHeapFactory:95] Cleared McPersistent location[../conf/persistent_stores/mc/]
    2020-02-23 19:33:27,323 INFO [main] [org.mycontroller.standalone.AppProperties:530] Created directory location: [/home/mycontroller/conf/persistent_stores/mc]
    2020-02-23 19:33:28,283 WARN [main] [io.moquette.persistence.mapdb.MapDBPersistentStore:78] Using fresh MapDB store file. Path=../conf/persistent_stores/moquette/moquette_store.mapdb
    2020-02-23 19:33:28,662 WARN [main] [io.moquette.server.Server:186] Using default SSL context creator
    2020-02-23 19:33:29,387 WARN [main] [io.netty.bootstrap.ServerBootstrap:146] Unknown channel option 'TCP_NODELAY' for channel '[id: 0x8057e12c]'
    2020-02-23 19:33:29,480 WARN [main] [io.netty.bootstrap.ServerBootstrap:146] Unknown channel option 'TCP_NODELAY' for channel '[id: 0x903a66e7]'
    2020-02-23 19:33:29,491 INFO [main] [org.mycontroller.standalone.mqttbroker.MoquetteMqttBroker:54] MQTT Broker started successfully. MqttBrokerSettings(enabled=true, sslEnabled=false, bindAddress=0.0.0.0, mqttPort=1883, mqttsPort=8883, websocketPort=7080, allowAnonymous=true, enabledOnBackend=true, sslKeystoreFile=null)
    2020-02-23 19:33:30,544 INFO [mc-th-pool-1] [org.mycontroller.standalone.gateway.mqtt.MQTTDriver:94] MQTT Gateway[name:Raspberry Pi, URI:tcp://localhost:1883, NetworkType:MyController] connected successfully..
    2020-02-23 19:33:30,587 INFO [main] [org.mycontroller.standalone.scheduler.SchedulerUtils:90] System jobs reloaded.
    2020-02-23 19:33:33,164 INFO [main] [org.mycontroller.standalone.StartApp:242] TJWS server started successfully, HTTPS Enabled?:true, HTTP(S) Port: [8443]
    2020-02-23 19:33:33,231 ERROR [Thread-9] [org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm:201] Exception, RawMessage:[aF-Q~Wï¿¿ï¿°ï¿£k↑Wï¿°브zタᄌcb↑�テ£ï¿ ï¿©ï¾˜ï¿£ï¿¡ï¿ ï¿©ï¿¸	a ̄タï¿£]
    org.mycontroller.standalone.exceptions.MessageParserException: Unknown message format:[aF-Q~Wï¿¿ï¿°ï¿£k↑Wï¿°브zタᄌcb↑�テ£ï¿ ï¿©ï¾˜ï¿£ï¿¡ï¿ ï¿©ï¿¸	a ̄タï¿£], gatewayId:5
    	at org.mycontroller.standalone.provider.mysensors.MessageParserAbstract.update(MessageParserAbstract.java:120)
    	at org.mycontroller.standalone.provider.mysensors.MessageParserSerial.getMessage(MessageParserSerial.java:32)
    	at org.mycontroller.standalone.provider.mysensors.MessageParserSerial.getMessage(MessageParserSerial.java:28)
    	at org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm.serialEvent(SerialDriverJSerialComm.java:170)
    	at com.fazecast.jSerialComm.SerialPort$SerialPortEventListener.waitForSerialEvent(SerialPort.java:937)
    	at com.fazecast.jSerialComm.SerialPort$SerialPortEventListener$1.run(SerialPort.java:885)
    	at java.lang.Thread.run(Thread.java:748)
    2020-02-23 19:33:33,843 INFO [main] [org.mycontroller.standalone.api.GoogleAnalyticsApi:94] Google analytics details[enabled:false, ga_anonymous_id:0904c9fb-6a3c-4c67-9ca8-908c0c2cb2f0]
    2020-02-23 19:33:33,844 INFO [main] [org.mycontroller.standalone.StartApp:139] MyController.org server started in [16494] ms
    2020-02-23 19:39:48,320 ERROR [Thread-9] [org.mycontroller.standalone.gateway.serial.SerialDataListenerjSerialComm:201] Exception, RawMessage:[|\ï¿¿{ï¿¢X
    


  • @skywatch I am sorry. I do not get any clue. Can you start your MyController instance with some delay (30s)?



  • @jkandasa No problem..... Mysteriously it seems to have resolved itself. Today is 'update' day for the pi and I thought I'd wake to a dead http connection. But no! - there was mycontroller running as normal. Maybe I just didn't give it enough time to settle down in previous tests......Ah well, it's alright at the moment so this is solved now! 😉 🙂 🙂 🙂


Log in to reply
 

Suggested Topics

6
Online

584
Users

470
Topics

2.9k
Posts