• Hello,
    First, you did a really good job with this controller.
    Now, after some hours, maybe 2 or 3, mycontroller start to consume a lot more cpu.
    At start, for about 15 seconde, cpu is at full load (390%) (quad core OPI) , then for 2-3 hours, it is at about 10%, and then it load the cpu at 200%+. i check this with htop.
    I tried updating java to 11. didn't change anything.
    tried oracle java --> didn't change anything too (but minecraft server doesn't work anymore)
    now i'm back to openjdk 8.
    it started when on 1.5 snapshot version, i've updated to stable 1.5.
    my database is about 100mo.
    Any idea ?

  • I don't think it is MyController causing the issue. It usually hums along with 4-10% on my pi 3B+. This is with no other servers etc running and only a small python script to control it's own cooling fan.
    Try disabling all other running items and see if that helps. If it does, re-enable them one by one until you find the culprit!

  • @Aneantisor Did you check CPU usage for MyController?
    Database size may be an issue.

    • How many nodes/sensors do you have?
    • What is the message(commands to your gateway and from your gateway) rate MyController will receive/send per minute?

    MyController is not supported yet for java > 9.
    For now, JDK 8 will be a good choice for MyController.

  • yes i gave you the cpu usage for mycontroller. not the whole system.
    i have 7 node and 56 sensors.
    the data rate is about 25 message per minute. maybe a little more.

    would it help to move to an mqtt gateway ?

  • @Aneantisor have you modified default data retention settings?
    If you increased the raw data retention settings, you may face this issue.
    Also for binary data, reduce the duration.
    We do not have any aggregation for binary data.
    Binary data will be kept as is.

    would it help to move to an mqtt gateway ?

    I believe gateway may not be an issue here.
    are you using serial gateway?

  • I'm tried with a new database, and the problem is gone.
    I'm now back with the old database, and i will check the data retention setting.
    Where can i find the default setting ?

  • @Aneantisor

    Where can i find the default setting ?

    Settings >> Metrics >> Data Retention Settings

    I believe the issue is due to binary data in your old database.

  • That was it. as soon as i turn binary data retention down to 30 days (was 1 year).
    Cpu dropped down.
    by "Where can i find the default setting ?" i mean default value.
    Thank you, you are really active.

  • @Aneantisor We do not have documented anywhere about default settings.
    When we do a fresh install we see default settings/values.

Suggested Topics