Unable to change node or sensor names



  • I hope someone can offer some advice. I have a network setup and all nodes seem to be running, triggering and following ActionBoard commands.
    However when I try to edit a sensor name

    <Resources> <Sensors> <Edit> , enter a new name and click <Save>

    I get a a pop-up which says

    400:Bad Request
    A sensor available with this sensor id!

    Any ideas on how to solve this??

    Chris


  • ADMIN

    @chrismills59 Can you check the sensorId assigned for some other sensors on this node?



  • Thanks for the reply.

    In my Sensors table I have 2 entries for the node, both with a Node EUI of 2. There are 2 sensors, the first with a SensorID of 3 and the other with a SensorID of 4.

    I get the same popup when trying to edit the sensor name for both sensors

    Chris



  • I think you should have one entry per node......see if that is where the problem is.....
    One node, two sensors. That is what you should be seeing.


  • ADMIN

    @skywatch In MySensors we can have 254 sensors per node. Reference: https://www.mysensors.org/about/network
    @chrismills59 can you send MyController version details? I try to reproduce this issue locally?



  • yes 🙂

    My misunderstanding - I thought the op had registered the node twice, once for each sensor....



  • Thanks everyone for advice so far. Having checked, I think I am running an older version.
    I'm always a bit reluctant to update something which seems to be working.

    Version Details

    MyController
    Version 0.0.3.Alpha2
    Database version 1.02.10 - 2016 Jul 29
    Git commit:branch e8afb0266ab685dcfc59b0691ec301d3a17d3fd6:master
    Built on 2016-07-30T01:04:37+0530
    Build JDK 1.8.0_92
    Build tool Apache Maven 3.3.9

    Java virtual machine specification
    VM vendor Oracle Corporation
    VM name Java HotSpot(TM) Client VM
    VM version 1.8.0_65-b17
    Java home /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre

    Operating system
    Operating system Linux
    Architecture arm
    Version/Kernel 4.4.34-v7+
    Location /home/pi/mycontroller/mycontroller


  • ADMIN

    @chrismills59 0.0.3.Alpha2 is too old, after this, I can see 3 more releases. can you try with the SNAPSHOT version and check this error?

    Kindly backup everything before moving into latest version.


 

Suggested Topics

12
Online

349
Users

327
Topics

2.0k
Posts