1.3.0 and 400:Bad Request



  • Hi

    I have this set up now on a pi3 with promini gateway and nrf24l01+.

    I have a node with 4 relays (and 4 local switches) that connects to the gw and then onto myc. So far so good.....

    But whenever I click the button to turn on or off a relay I always get the 400: Bad Request error pop-up (followed with ack data). I do not know how to solve this...

    Any ideas ????


  • ADMIN

    @skywatch Can you check it on network response in the browser? also, check the MyController.log.
    clearing cache resolves the issue some time.

    UPDATE: Initially, I understand your query wrongly. I guess the problem with the range. Can you disable the ack for that gateway and check it?



  • Range wasn't the issue as the relays still operated, just kept getting that damn pop-up message!

    I have disabled ack in the gateway and node, no more pop-ups. But now I don't know for sure the status of the relays and so back to the old problem of 'is it off or is it on?'

    As an aside, I have tracked some issues down to bad dupont cables from china - now soldering wires directly instead on new modules once the node works as intended....

    Anything you can suggest to get ack working without errors?


  • ADMIN

    @skywatch It is strange, that without ack it works for you and with ack is not working 😞
    can you post your gateway setting edit page? I want to see values for,

    • Ack enabled
    • Failed retry count
    • Ack wait time(Milliseconds)


  • No problem....

    Ack enabled - Ticked
    Failed retry count - 7
    Ack wait time(Milliseconds) - tried 2000 and 3500
    

    Thanks for the help 😉


  • ADMIN

    @skywatch All the values look better. Ack wait time(Milliseconds) value 2000 is big enough.
    Till now I didn't get any clue.

    Can you enable DEBUG for the followings and send the mycontroller/logs/mycontroller.log log file?

      <logger level="DEBUG" name="org.mycontroller.standalone.provider" />
      <logger level="DEBUG" name="org.mycontroller.standalone.provider.mysensors" />
    
      <logger level="DEBUG" name="org.mycontroller.standalone.gateway" />
      <logger level="DEBUG" name="org.mycontroller.standalone.gateway.ethernet" />
      <logger level="DEBUG" name="org.mycontroller.standalone.gateway.mqtt" />
      <logger level="DEBUG" name="org.mycontroller.standalone.gateway.serial" />
    
    


  • Of course! 🙂

    Give me a few days as its the World Cup and amazingly England are still hanging in there 🙂


  • ADMIN

    @skywatch Sure, enjoy! have a fun time



  • @jkandasa I am sorry I didn't get back to this sooner, but as you know I have other issues taking my time.

    So today I still get

    0_1539635035595_400.jpg

    I will add the debug and see what happens...But what is the message actually telling me? It seems that the message was sent OK and ack received, no?


  • ADMIN

    @skywatch Message says, received acknowledgment
    For this message should not throw 400 🙂 I hope we have some issue in the code. For good message, it says as bad.



  • @jkandasa said in 1.3.0 and 400:Bad Request:

    I hope we have some issue in the code. For good message, it says as bad.

    That's what I thought. I am now using latest 1.4.0 snapshot FYI.

    Trouble is that sometimes when this happens it resends the command. My amplifier only has one button that toggles the power on and off, no descrete commands. The result is the amp turns on and off and on and off and on and off (You get the idea and how annoying it is).


  • ADMIN

    @skywatch can you send gateway raw message on this particular period(error occurred)?



  • @jkandasa I will try and replicate this tonight/tomorrow and send you the log.

    🙂


 

Suggested Topics

13
Online

392
Users

365
Topics

2.2k
Posts