keystore/certificate and now cannot connect to web page on pi



  • Re: keystore and certificate on client
    I followed the instructions on the above topic by doing the following on the pi.....
    [code]
    cd /home/mycontroller/conf

    sudo keytool -genkey -alias selfsigned -keyalg RSA -keystore keystore.jks -validity 360 -keysize 2048

    sudo keytool -export -alias selfsigned -keystore keystore.jks -file root.cer
    [/code]
    The key was exported and copied to PC. It was successfully installed in win10 , but now I cannot access MYC via web. I tried my new and the old password without success........

    How can I get out of this situation (with easy steps please!) 😉



  • UPDATE - So I deleted the keystore.jks file and started again 🙂
    This time I get to the point of a .cer and .crt file. I install cert in win 10 and see it in Firefox->tools->options->advanced->certificates and it is in there with the correct ip address of the pi. But when I connect to it I still get the warning that the page is not secure and have to click through to view it. What could I have done wrong? How can I fix this?
    At lease I can see my graphsa gain thou 😉



  • So now I have a strange situation.

    In Firefox (54.0.1 32bit) I see the cert in the servers column. If I try to make an exception it says I don't need to as the site is serving a valid certificate. But when I load the page I always get the security warning. Arrrgggghhhhh.....This is driving me nuts! ???


  • ADMIN

    @skywatch When we go with SSL certificate we always get the security warning. To avoid SSL certificate warning you have to create CA certificate.

    Simply you can ignore this SSL certificate warning. What is the issue are you facing this default certificate?

    If you want CA certificate https://letsencrypt.org for free 🙂


 

Suggested Topics

6
Online

334
Users

318
Topics

1.9k
Posts