UID Tags disappear....



  • Hi!,

    Has been some time, and still enjoying MyController very very much!, running into some issue, where i am not sure if this is known. I upgraded to the latest and greatest release, and I got every thing up and running in a couple of minutes by restoring the database. All settings and data is back!!

    Since the upgrade i run into the issue that my UID Tags are gone after a couple of days. The page containing the UID Tags is simply empty..I have some gauges running which depend on the tags, and I need to recreate them every week at least twice...

    Is this a known issue?

    Thanks

    Kind regards,

    Tag


  • ADMIN

    @Tag Yes, I too face this issue last few days. Looking the issue. Till now could not find it. Hopefully will fix it soon. Thanks to report this!

    Created a ticket to track this one >> https://github.com/mycontroller-org/mycontroller/issues/331



  • Thank you!!


  • ADMIN

    @Tag I have added fix, kindly check it on latest SNAPSHOT version



  • @jkandasa

    Hi!,
    Downloaded, installed and restored the database!.
    Seems to work okay at first sight, however if i use the gauge (that worked fin in the previous version) it stays empty... nothing is shown. All scripts / templates / headers are untouched.

    Any idea what could be the issue?

    Example

    Header:
    //Load sensor variable data with UID-TAG identification
    var temperatureSen = mcApi.uidTag().getByUid("cv-temp");
    //Generate UUID, for html widget
    var uuid = mcApi.utils().getUUID();

    Template:
    <div id="wrapper" style="text-align: center">
    <canvas id="my-gauge-${uuid}" style="display: inline-block;"></canvas>
    <div style="font-size:21px ; font-weight:bold" id="textfield--${uuid}"></div>
    </div>
    <script>
    var opts = {
    lines: 12,
    angle: 0.05,
    lineWidth: 0.44,
    pointer: {
    length: 0.9,
    strokeWidth: 0.035,
    color: '#303030'
    },
    limitMax: 'false',
    percentColors: [[0.0, "#a9d70b" ], [0.90, "#f9c802"], [1.0, "#ff0000"]], // !!!!
    strokeColor: '#b0b0b0',
    generateGradient: true
    };
    var target = document.getElementById('my-gauge-${uuid}'); // your canvas element
    var gauge = new Gauge(target).setOptions(opts); // create sexy gauge!
    gauge.animationSpeed = 3; // set animation speed (32 is default value)
    gauge.minValue = 10; //Maximum value
    gauge.maxValue = 82; //Maximum value
    gauge.setTextField(document.getElementById("textfield--${uuid}"));
    gauge.set(${temperatureSen.sensorVariable.value}); // set actual value
    </script>

    <!--see http://jsfiddle.net/berni/Yb4d7/ for example-->

    HTML Header:

    https://217.123.123.148:8443/mylib/gauge.min.js

    UUID Tag cv-temp is pointing to one of my sensors

    This is just an example, of a setup that worked in the previous version


  • ADMIN

    @Tag Which browser are you using, looks like it works only on google chrome, There is bug: https://github.com/mycontroller-org/mycontroller/issues/338


  • ADMIN

    @Tag said:

    https://217.123.123.148:8443/mylib/gauge.min.js

    You have to create above script once again. This will not be covered on backup.

    There was an issue, pushed the fix on latest SNAPSHOT build.


  • ADMIN



  • @jkandasa

    Okay!, will download and test the snapshot asap!!

    Thank you for your great software and support!!



  • @jkandasa

    You fixed it!!, just tested, and gauges work perfectly again...
    Thanks!!


Log in to reply