Send Email (Bug)?



  • Set up a timer to send email. The following displays when looking at the log.
    2016-12-27 18:56:00,009 ERROR [Quartz_Scheduler_Worker-4] [org.mycontroller.standalone.operation.model.OperationSendEmail:145] Timer will not support for this operation.
    SMTP tests correctly.
    No email is sent. Is this a bug? Or doing it incorrect.

    Ultimately what i would like to achieve is that if there is any valve on. to send a reminder msg. List running valves. (In email) (System to check at Scheduled Rule time 6pm) Save running the valves all night if manually set and forget to turn off. (I have Timer schedules set that also write to variable but this should not matter as these look after them self) Valves do not write to a variable if Manually triggered On)



  • Further more on this i have found that in a post it may not be supported using timers. I have attempted to also use a rule. Monitor a valve for Active (on) time set to 20secs (Test) then to send email. This also does not work. But... Setting the rule to just look at ==On. Triggers an email event straight away. Whats the best way to monitor all Valves and running time and send email if on for X time?


  • ADMIN

    @gouds I believe you are using 0.0.3.Alpha2, You can find in SNAPSHOT build that, timer supports email via https://github.com/mycontroller-org/mycontroller/issues/301

    For snapshot build refer http://forum.mycontroller.org/topic/58/download-snapshot-build


  • ADMIN

    @gouds said:

    I have attempted to also use a rule. Monitor a valve for Active (on) time set to 20secs (Test) then to send email

    This should work. I will check this and update you. Thank you!



  • I can now confirm email from a timer works by using the new distro :) Thanks

    However the below does not seem to work correctly. Does not trigger an email. (Perhaps i am doing this incorrectly)

    The 0_1482879717922_upload-cc9a90c0-decb-4b07-874f-613b5d749d2f


  • ADMIN

    @gouds Yes, I will check this issue soon and update you.


Log in to reply