Setting Time Zone

  • Hi Guys,
    I have MC on a server that uses PST as a timezone. Im unable to change this (Limitation of the NAS) to my local region. Is there a way to explicitly set the time zone for MC my TZ. When i go into MC i get the server time. Or is it possible to set the Java instance to a time zone leaving the local server as is.


    @gouds Seems we can change the timezone for JVM. See this thread for more details.

    In MC you have to put entry in the location >> mycontroller/bin/

    line #54,

              $_java ${HEAP_MIN} ${HEAP_MAX} -Duser.timezone=Europe/Sofia -Dlogback.configurationFile=${CONF_LOG_FILE} -Dmc.conf.file=${CONF_PROPERTIES_FILE} -cp "../lib/*" org.mycontroller.standalone.StartApp >> ../logs/mycontroller.log 2>&1 &

    Please note: I did not test this one.

  • Hello,

    I installed the MC on cloud server.
    I have set the timezone, and if we entry "date" command, display the proper my local time.
    However, in mycontroller dashboard, the timezone is still not change, display UTC(+0000).

    How to setup the timezone display in the MC dashboard ?


  • Don't worked for me, any other idea ?

  • Also looking for a solution for this. Mine is stuck at "CEST (+0200)" and is actually one hour ahead. Very annoying.


    @Redferne Can you check your java version is latest one?

  • pi@raspberrypi:~ $ java -version
    java version "1.8.0_65"
    Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
    Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)

    The latest oracle-java8-jdk for Raspbian Jessie.


    @Redferne Do logout and login from MC GUI and check once again.

  • Yes. Logout and Login corrected my time. Thanks!

  • @kadu after 3 days the timezone parameter worked to me! (tks @jkandasa )

  • Fixed for me too, I was having the wrong time on Chrome browser, while on Safari was correct.
    With logout and login.

Log in to reply