Node Reboot



  • Hi @jkandasa,

    I have a question about the Reboot option under Nodes > Actions > Reboot and Refresh Nodes Info

    Can you explain what these two options are supposed to achieve? When I select a node and then execute the Reboot it seems to take the node offline requiring a manual reset by power cycling it.

    I am unsure what happens with Refresh Nodes Info, I click and nothing seems to change.

    Thanks,


  • ADMIN

    @imedia

    Reboot triggers reboot of the node. I have noticed that if our node not running with MySensorsBootloaderRF24 and working with default arduino boot loader, it structs when we trigger reboot via MySensors. I do not know why.

    Refresh node info triggers void presentation() method of your node. Whatever you put on void presentation() will be updated in controller.



  • Ok thanks for the info @jkandasa ,

    Do you know of any documentation that properly explains the use and installation of the MySensorsBootloaderRF24 process?

    I would really like to also get the remote firmware update as part of MyController working as well and I understand the bootloader is required. If that also resolves this issue perfect!

    Documentation seems scarce on all of this so any help is much appreciated!


  • ADMIN

    @imedia

    follow this and this

    also this will be called as MYSBootloader

    to burn this bootloader you have to use usbasp programmer or king of.



  • Thanks again @jkandasa



  • Been working on this a bit more... The documentation / guides in the links you provided are a bit over my head. I'm not familiar with the purpose of fuse settings and other bootloader characteristics, perhaps this is a little too low-level for me...

    Is there not a guide that is a bit more step by step to get a working system using the MYSBootloader? I seem to just be going in circles with the forum posts and technical details I cannot make sense of, and the dialogue is way over my head. I'm not technically inept, or at least I don't think I am, but do know I'm not a low-level programmer.

    Perhaps a quick guide on how to get a system working would help many leaving out all the jargon? Am I alone?


  • ADMIN

    @imedia I believe you will be using your radio on default channel that is 76. If so, you no need to change anything, simply burn given bootloader hex file directly to your arduino board with the help of uspasb of similar kind of programmer.

    Take the default one from here. https://forum.mysensors.org/uploads/files/1475275020003-mysbootloader_v13pre2.zip

    You have to use uspasp on command line not on arduino IDE.


  • ADMIN

    @imedia This is commands I used to follow, to write MYSBootloader,

    avrdude -cusbasp -Pusb -b115200 -pm328p -e -u -Ulock:w:0x3f:m -qq -Uefuse:w:0x06:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xF7:m -Ulock:w:0x0f:m
    avrdude -cusbasp -Pusb -b115200 -pm328p -V -q -s -Uflash:w:MYSBootloaderV13pre.hex
    avrdude -cusbasp -Pusb -b115200 -pm328p
    

Log in to reply