OTA firmware update with external MQTT broker



  • I've been testing more... It seems that in order for the new firmware to be loaded to the node and then show as running in MyController the node needs a hard reset (pull power and restore). Issuing reboots from the controller does not seem to work.

    I've yet to figure out what combination of things is actually triggering the update though. I just keep trying different things and eventually it works. But consistently the new firmware version will not be shown in MyController until a hard reset on the node is completed.

    I'm using 5v 16Mhz Pro Mini.

    I've also noticed that once the firmware version has been put on a node I can't re-send the same version, I need to increment the versions everywhere. Is this correct or should I be able to re-flash with the same firmware version by issuing the command?



  • @imedia said:

    Issuing reboots from the controller does not seem to work.

    I do not know what causes this issue for you. Hence I could not reproduce this issue locally in my environment. I am using pro mini 5 volt cloned version and MySensors version 2.0.1-beta

    I've also noticed that once the firmware version has been put on a node I can't re-send the same version, I need to increment the versions everywhere. Is this correct or should I be able to re-flash with the same firmware version by issuing the command?

    Yes, this is known limitation on MySensors. To avoid firmware update on every reboot. If you have any changes on your firmware, your CRC will be changed. Then node will consider it a new firmware. Node will check three things type, version and CRC, if either once is changed node assumes that there is anew firmware available for me and run firmware update.



  • @jkandasa Hi jkandasa,
    I did upgrade with SNAPSHOT version from google drive.
    Seems it works fine but I'm unable to select firmware from node. There are many firmware in utilities.
    Do you know this issue?
    Thank you in advance.



  • @jkandasa Oh, it works now. I have to restart after restore from backup.
    After restart server then I'm able to see all firmware^^ however I can't see smart sleep option on firefox.
    I can see it on chrome.



  • @yd Thanks to report this. Could you please remove your browser cache on firefox. It could be a firefox browser caching issue.

    Please report SmartSleep support status with MyController. I didn't test this feature as I do not have any SmartSellp node.

    Thank you!



  • @jkandasa You are right. It's working now after clear cache. There is no plan to firmware upgrade at this moment. I will let you know when I do test this function.



  • I can confirm smartsleep works fine with mysensors 2.0.0 (battery powered arduino pro mini 3.3V )
    Thank you for your support! This is awesome controller!



  • @jkandasa

    Hi SmartSleep is now working for me thank you this is great I haven't yet tested all the commands but have noticed you are forced to enter a sensor ID as well as the node id on internal commands such as reboot and present when the sensor id is not relevant.

    I have also noticed that the name field doesn't seem to get updated when a presentation request is made after first registration. This may be intentional though as people may wish to display a different name to that presented. May be worth having a name field and a known as field just a thought.

    I'm attempting to get OTA updates working using dualoptiboot. I have it operating using MYScontroller so know the nodes are accepting the firmware ok. In your post you mention for dualoptiboot you need to click Update firmware. Any help on where I may find this in the UI would be appresiated.

    On a testing front I have noticed a few small niggles one of those being the filter and sort options at the top of each page don't seem to persist past page refreshes.

    Hope this is helpful



  • @Doug

    I haven't yet tested all the commands but have noticed you are forced to enter a sensor ID as well as the node id on internal commands such as reboot and present when the sensor id is not relevant.

    I hope you passing commands via Send Raw message page. Which is not require. Suppose if you want to reboot smartsleep node. Just select that node on Resources >> Nodes >> your node on actions click on Reboot. This command will be send to SmartSleep node when it talks to MyController.

    I have also noticed that the name field doesn't seem to get updated when a presentation request is made after first registration. This may be intentional though as people may wish to display a different name to that presented. May be worth having a name field and a known as field just a thought.

    Yes, this is addresses on this requirement. However if your node sends some name will be overridden. It will not change only when node sends NULL or "" no values.

    I'm attempting to get OTA updates working using dualoptiboot. I have it operating using MYScontroller so know the nodes are accepting the firmware ok. In your post you mention for dualoptiboot you need to click Update firmware. Any help on where I may find this in the UI would be appresiated.

    I believe it should be on user manual. And here is the steps.

    • Update your firmware under Utilities >> Firmwares
    • Edit your node and select your uploaded firmware for a node [Resources >> Nodes >> select a node and on actions Edit] finally save the configuration.
      *MyController ready to send your firmware to your node. Select your node under Resources >> Nodes >> your node and on actions select Upload firmeware

    On a testing front I have noticed a few small niggles one of those being the filter and sort options at the top of each page don't seem to persist past page refreshes.

    Yes, This is known limitation. If possible I will address this. Kindly create a ticket on github project page

    Hope I have addressed your queries.



  • I am very new to this. Sorry for stupid questions.

    @jkandasa I have still issues with OTA. It is uploading spontaneously to a wrong node? Anyone here has maybe a bootfile for 8MHZ node which should work correctly? (Also serial works?) and is there a clear description of how it should work. I have added the firmware but if I select the node and upload firmware I cannot select the firmware version only with the edit mode.

    Thanks for any help.



  • @Marcel said in OTA firmware update with external MQTT broker:

    I am very new to this. Sorry for stupid questions.

    The only stupid questions are the ones you don't ask!

    We are all on a learning curve here and it takes time. Stick with it!

    OTA I have not tried yet, but will in the coming months as I have outdoor nodes that would benefit from this. So if you get it going, please tell us how! 😉



  • @Marcel Can you post some of the screenshots? I will help us to understand easily.



  • @jkandasa

    I am trying to understand the logic of the program. But what I expect is the following:

    2019-01-12 09_31_00-MyController.org - The Open Source Controller.png

    When I press the upload firmware I see a list where I can choose the firmware from and upload it. But that seems not the case after trail and error. So let me explain what I think it works.

    When I have a new node, this will publish an auto node ID. Then I cannot upload new firmware because if I do this the default firmware will be loaded ? I am not sure if that is even possible with manually assigned numberings of nodes.
    So the next step is that I press edit on the new node and assign the firmware to it (that I added to utilities\firmware tab) and save this and the press the above button upload firmware? This seems to work but I am not sure if this is the correct process as I find this not very logical.

    When I would like to update a node, I add the software again to the utilities\firmware tab, edit the specific node and assign this new software and do the upload firmware again? Correct?

    The part where it did goes wrong is that I put the default switch on for firmware as I saw errors in the logging about this. Then this will upload software (which is already on another node) to the new node and you get duplicated node numbers.

    So preferable, I would like to see. Add also the possibility that you have a split menu. Upload Assigned/default firmware or upload firmware where you get a popup and select the one you would like to upload to your node.

    Secondly, I had a problem with my boot software. The first time it advertises itself and after the upload of the new firmware, I could never upload new firmware again. I have downloaded the MySensors Bootloader and recompiled it for my hardware (slim node atMega328p 8MHz) and this bootloader seems to work okay 🙂



  • @skywatch
    Thanks 🙂



  • @Marcel I am out of town, I will soon respond for your query. Thanks for the patience.



  • @jkandasa okay



  • @Marcel Thank you for your patience!

    OTA works in the following way,

    • send available firmware details(version, checksum, etc.,) to the node
    • If node thinks, it is a different sketch, it will request block by block.
    • MyController sends firmware block data(requested block)

    When I have a new node, this will publish an auto node ID. Then I cannot upload new firmware because if I do this the default firmware will be loaded? I am not sure if that is even possible with manually assigned numberings of nodes.

    Assigning node ID is a different process than OTA. So do not get confuse with node ID assignment.

    So the next step is that I press edit on the new node and assign the firmware to it (that I added to utilities\firmware tab) and save this and the press the above button upload firmware? This seems to work but I am not sure if this is the correct process as I find this not very logical.

    Yes, this is the correct way to upload firmware and it is by design. You can keep any number of version of the firmware and assign a version to a particular node.

    When I would like to update a node, I add the software again to the utilities\firmware tab, edit the specific node and assign this new software and do the upload firmware again? Correct?

    Yes, correct

    The part where it did goes wrong is that I put the default switch on for firmware as I saw errors in the logging about this. Then this will upload software (which is already on another node) to the new node and you get duplicated node numbers.

    Default firmware should not contain node id statically. It is mainly used when we use MYSBootloader. With this boot loader, we may not have any firmware. So we can keep default firmware for the first time. and later we can switch to new firmware by assigning manually.

    That is up to our convenience. We can go without default firmware also.
    You can disable it as follows,
    461787f1-c759-4063-9c35-8af7e073c66d-image.png

    So preferable, I would like to see. Add also the possibility that you have a split menu. Upload Assigned/default firmware or upload firmware where you get a popup and select the one you would like to upload to your node.

    Yes, nice feedback/enhancement request. Could you please create a ticket in GitHub?

    Secondly, I had a problem with my boot software. The first time it advertises itself and after the upload of the new firmware, I could never upload new firmware again. I have downloaded the MySensors Bootloader and recompiled it for my hardware (slim node atMega328p 8MHz) and this bootloader seems to work okay 🙂

    Great! I hope you have mentioned MYSBootloader ^^


Log in to reply
 

Suggested Topics

4
Online

475
Users

407
Topics

2.5k
Posts