0.0.3.Final pre-release - volunteers required to test


  • ADMIN

    0.0.3.Final release almost ready. We need pre-release test volunteers.

    you can find SNAPSHOT version here

    If you face any issues kindly report it on GitHub Issues page

    Happy testing :)


  • ADMIN

    Here I am listing new additions.



  • Hi! i want to test please!!


  • ADMIN

    @Tag Thank you for your support. you can test SNAPSHOT version,

    http://forum.mycontroller.org/topic/58/download-snapshot-build



  • Updated!!, restored database everything is back again!

    Thanks!!



  • backup, install 0.0.3.Final, restore: everything is ok for me also. thanks



  • nice! I noticed the MCAgent "thing" - is that a gateway replacement?

    At the moment I run the mysGateway from marceloaqno, but since today have problems with it (because I did a raspberry apt-get dist-upgrade which broke my system somehow. So I'm wondering if changing to the new MCAgent would be an option for me...

    Ideally I would like to keep the gateway functionality so that I could connect from another computer to the gateway to inject messages and also debug the traffic.

    At the moment I see not much documentation about the MCAgent - maybe someone knows more about it?!



  • Just try the new version and I got an issue, when trying to add a widget on the dashboard, the "Sensor variable" is empty (Does the same for all widget type ).
    The same issue in "Ressources->Operations" with :
    type=send playload
    Sensor variable = empty list.

    Rollback to the old version, the list appear.



  • I don't know what happen but this morning I try from my phone and it was working. And now it's working on computer with both chrome and safari.


  • ADMIN

    @Velo17

    I noticed the MCAgent "thing" - is that a gateway replacement?

    For now MCAgent supports only for raspberry pi io pins.(It is a gateway type in MyController). It will not support for MySensors


  • ADMIN

    @Fraid said:

    I don't know what happen but this morning I try from my phone and it was working. And now it's working on computer with both chrome and safari.

    I guess it might be browser caching issue.



  • With the last release : Application information: [Version:0.0.3.Final-SNAPSHOT, Database version:1.03.05 - 2016 Nov 18, Built on:2017-01-16T22:09:06+0530, Git commit:21d0b3a52ab32e475afb53e0a832146ca678b015:development]

    when I try to restore database, I have this in log :

    2017-01-17 09:52:35,950 INFO [main] [org.mycontroller.standalone.StartApp:108] MyController.org server started in [54734] ms
    2017-01-17 09:57:45,673 INFO [Acme.Utils.ThreadPool(5)-PooledThread: Acme.Serve.Serve$ServeConnection@197cc8d] [org.mycontroller.standalone.api.BackupApi:219] Restore triggered.
    2017-01-17 09:57:48,682 INFO [Thread-15] [org.mycontroller.standalone.backup.Restore:69] About to restore a backup, BackupFile(name=on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, canonicalPath=/mycontroller/backup/on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, timestamp=1484642759000, size=65615)
    [Tue Jan 17 09:57:48 CET 2017] Accept: java.net.SocketException: Socket closed
    2017-01-17 09:57:49,097 WARN [MyController.org Shutdown-Hook] [org.knowm.sundial.SundialJobScheduler:140] Scheduler has not yet been created!!! Call "createScheduler" first.
    2017-01-17 09:57:49,117 INFO [MyController.org Shutdown-Hook] [org.mycontroller.standalone.AppShutdownHook:36] Bye, Have a nice day! See you soon
    

    And nothing is restored... :(
    Do you have an idea ?
    Thanks


  • ADMIN

    @Tetnobic Can you try with latest SNAPSHOT version? We might have fix for this issue.

    I am sorry, you are already with latest. Can you send your backup file. Let me try locally? jkandasa at gmail dot com



  • @jkandasa No problem, sended



  • @jkandasa
    Problem with mail, you can download the backup file here :
    **....



  • If I backup the "empty" new release, and try to restore, same problem....
    I think the problem not comes from my backup file


  • ADMIN

    @Tetnobic I do not see any problem, It is perfectly working for me.However, I have uploaded SNAPSHOT version with my current source code. After the restore, I see all the data.

    2017-01-17 15:26:03,009 INFO [main] [org.mycontroller.standalone.StartApp:108] MyController.org server started in [4092] ms
    2017-01-17 15:26:36,309 INFO [Acme.Utils.ThreadPool(1)-PooledThread: Acme.Serve.Serve$ServeConnection@59212887] [org.mycontroller.standalone.api.BackupApi:219] Restore triggered.
    2017-01-17 15:26:39,312 INFO [Thread-15] [org.mycontroller.standalone.backup.Restore:69] About to restore a backup, BackupFile(name=on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, canonicalPath=/home/jkandasa/Downloads/on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, timestamp=1484646665000, size=65615)
    [Tue Jan 17 15:26:39 IST 2017] Accept: java.net.SocketException: Socket closed
    2017-01-17 15:26:39,581 INFO [Thread-15] [org.mycontroller.standalone.mqttbroker.MoquetteMqttBroker:66] MQTT Broker has been stopped successfully
    2017-01-17 15:26:39,948 INFO [Thread-15] [org.mycontroller.standalone.db.DataBaseUtils:285] Database restore completed. Database url:jdbc:h2:file:../conf/mycontroller;MVCC=TRUE, Restored file name:/storage/work/projects/mycontroller-org/mycontroller/dist/target/mycontroller/bin/tmp/on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06/database_backup.zip
    2017-01-17 15:26:40,096 INFO [Thread-15] [org.mycontroller.standalone.backup.Restore:153] Restore completed successfully. Start 'MyController.org' server manually
    2017-01-17 15:26:40,100 WARN [MyController.org Shutdown-Hook] [org.knowm.sundial.SundialJobScheduler:140] Scheduler has not yet been created!!! Call "createScheduler" first.
    2017-01-17 15:26:40,100 INFO [MyController.org Shutdown-Hook] [org.mycontroller.standalone.AppShutdownHook:36] Bye, Have a nice day! See you soon 
    


  • @jkandasa
    I try your last SNAPSHOT
    It works !!

    2017-01-17 11:21:22,144 INFO [Acme.Utils.ThreadPool(4)-PooledThread: Acme.Serve.Serve$ServeConnection@1084a4e] [org.mycontroller.standalone.api.BackupApi:219] Restore triggered.
    2017-01-17 11:21:25,163 INFO [Thread-15] [org.mycontroller.standalone.backup.Restore:69] About to restore a backup, BackupFile(name=on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, canonicalPath=/home/pi/workspace_domotic/MyController/mycontroller/backup/on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06.zip, timestamp=1484648459000, size=65615)
    [Tue Jan 17 11:21:25 CET 2017] Accept: java.net.SocketException: Socket closed
    2017-01-17 11:21:25,524 INFO [Thread-15] [org.mycontroller.standalone.mqttbroker.MoquetteMqttBroker:66] MQTT Broker has been stopped successfully
    2017-01-17 11:21:28,259 WARN [MyController.org Shutdown-Hook] [org.knowm.sundial.SundialJobScheduler:140] Scheduler has not yet been created!!! Call "createScheduler" first.
    2017-01-17 11:21:28,290 INFO [MyController.org Shutdown-Hook] [org.mycontroller.standalone.AppShutdownHook:36] Bye, Have a nice day! See you soon
    2017-01-17 11:21:35,797 INFO [Thread-15] [org.mycontroller.standalone.db.DataBaseUtils:285] Database restore completed. Database url:jdbc:h2:file:../conf/mycontroller;MVCC=TRUE, Restored file name:/home/pi/workspace_domotic/MyController/mycontroller/bin/tmp/on-demand_mc_backup_h2db_embedded-2017_01_17-09_35_06/database_backup.zip
    2017-01-17 11:21:35,817 INFO [Thread-15] [org.mycontroller.standalone.backup.Restore:153] Restore completed successfully. Start 'MyController.org' server manually
    

    Data retore complete log message is show 7 seconds after shutdown message log, but it works

    Sorry for the inconvenience
    And many thanks for your reactivity


  • ADMIN

    @Tetnobic

    Data retore complete log message is show 7 seconds after shutdown message log, but it works

    Looks like taking some time to restore on your machine.
    However, the following message says shutdown complete. Which leads confusion for you. I will sync these messages. Thank you! No worries :smile:

    2017-01-17 11:21:28,290 INFO [MyController.org Shutdown-Hook] [org.mycontroller.standalone.AppShutdownHook:36] Bye, Have a nice day! See you soon
    
    

  • ADMIN

    @Tetnobic fixed this restore issue on the slow environment too. Thanks to reporting this issue. This is a nice catch! Updated changes on SNAPSHOT build.

    https://github.com/mycontroller-org/mycontroller/commit/14c791726b833905ce5ecc69853e2fca1b33b361



  • Hi,

    Just downloaded latest snapshot uploaded today of 0.0.3-final.
    I am unable to login. The login screen just sits there, reporting no errors.
    Can somebody confirm this?

    Thanks.


Log in to reply