Mesh network and gateway?



  • Hi there, I am new to mycontroller and mysensors and its a little steep right now, but it looks really promising.

    My plan is to rig up about 10 ESP8266 boards with a few sensors in a mesh network https://github.com/Coopdis/easyMesh

    I have a Ubuntu server running in the house, with mycontroller.org running, but I cant seem to find a gateway I can install on the Ubuntu server that acts as a connection between the mesh network and the controller....?


  • ADMIN

    @njbuch I never worked with https://github.com/Coopdis/easyMesh

    However, MyController has an own implementation for ESP8266 (It does not support for mesh). You can have a look at https://github.com/mycontroller-org/MyControllerDevice



  • @jkandasa Hi there, thanks for replying! :)

    I have looked at the https://github.com/mycontroller-org/MyControllerDevice code, and it seems to be missing a "getting started" guide, or at least a small instruction as to where these files should be compiled, and how to upload them to the board. If its an Arduino library, there is a missing library file and some initial sketch.

    I am hoping you could help with that, I will happily polish it and write docs when its works to me, if you could get me started...



  • Ping, did this disappear from the radar?


  • ADMIN

    @njbuch I am sorry for the delay. I was bit busy with other tasks. I will generate a getting started soon. Thank you for your patience.


  • ADMIN

    @njbuch I have updated quick start guide. Kindly let me know if you face any issue.

    https://github.com/mycontroller-org/MyControllerDevice



  • Super awesome, thank you very much, will give it a spin and contribute as good as I can! Thanks!!



  • Hi again, I have now installed the mycontroller server on my Ubuntu box and configured to your instructions, and got the ESP8266 device configured and tested with the code provided.

    The device seems to work as the log says:

    MC: Configuration(NodeEUI:[ESP_0B9892], FeedId:[esp], Mqtt{Server:[192.168.1.197], Port:[1883], User:[]})
    MC: Connecting to WiFi with ssid[1421530] and with password.........OK
    MC: WiFi BSSID:[00:02:61:A8:32:58], RSSI:[-74 dBm, 52 ], IP:[192.168.1.103]
    MC: MQTT settings(Broker:[192.168.1.197], Port:[1883])
    MC: MQTT authenticating as anonymous
    MC: MQTT connected :)
    MC: MQTT topic subscribed:[in_esp/ESP_0B9892/#]
    MC: Initialization done...
    

    But there is no sign of the node popping up on the mycontroller server, and when I try sending a raw message to the device with the NodeEUI ESP_0B9892 and sensor relay-1

    It fails in a HTTP request with this log-item:

    2017-02-02 23:19:56,735 ERROR [Thread-4] [org.mycontroller.standalone.message.MessageMonitorThread:70] RawMessage[RawMessage(gatewayId=1, data=1.0.0, subData=out_esp/ESP_0B9892/SENSOR_BC/C_PRESENTATION/S_ARDUINO_NODE/0, isTxMessage=false, networkType=MY_SENSORS)] throws exception while processing!, 
    java.lang.NumberFormatException: For input string: "ESP_0B9892"
    

    I am unsure as where I can find the new node, and if the node is automatically added to a list somewhere, and how I can configure it to belong in a room, and expose the correct sensors....?

    Thanks


  • ADMIN

    @njbuch Use latest SNAPSHOT version and configure gateway as shown here, For complete details refer this location

    mc_01



  • @jkandasa Upgrade to the latest SNAPSHOT release. And it seems to work.

    But the MyControllerDevice...

    But it seems there is an incompatibility with some ESP8266 boards. Its working on the LoLin board NodeMCU v3, but not on the Wemos D1 mini 2.1.0.

    The Wemos keeps restarting and outputs:

    ets Jan  8 2013,rst cause:2, boot mode:(3,6)
    
    load 0x4010f000, len 1384, room 16 
    tail 8
    chksum 0x2d
    csum 0x2d
    v00000000
    ~ld
    

  • ADMIN

    @njbuch Did you select correct version of ESP board when you compile?



  • I am pretty sure, other examples are working with that configuration. I just pulled the most recent version of the code, and got a glimpse of the error message:

    MC[I]: Booting ESP8266 device...
    
    Exception (28):
    epc1=0x4020e012 epc2=0x00000000 epc3=0x00000000 excvaddr=0x00000000 depc=0x00000000
    
    ctx: cont 
    sp: 3fff1e70 end: 3fff2070 offset: 01a0
    
    >>>stack>>>
    3fff2010:  3fffdad0 3fff0108 3fff0f80 4020497b  
    3fff2020:  00000000 00000000 00000000 feefeffe  
    3fff2030:  3fffdad0 00000000 3fff0108 402049e9  
    3fff2040:  feefeffe 00000000 3fff1034 402023a4  
    3fff2050:  feefeffe feefeffe feefeffe 4020c19c  
    3fff2060:  feefeffe feefeffe 3fff1050 40100718  
    <<<stack<<<
    
     ets Jan  8 2013,rst cause:2, boot mode:(1,6)
    
    
     ets Jan  8 2013,rst cause:4, boot mode:(1,6)
    
    wdt reset
    

  • ADMIN

    @njbuch Can you give your source code? for this error?



  • Yep, its the unedited source and the board-defs is the newest downloaded from https://github.com/esp8266/Arduino.git esp8266

    https://github.com/mycontroller-org/MyControllerDevice/blob/master/examples/RelayActuator/RelayActuator.ino

    The board is the https://www.wemos.cc/product/d1-mini.html

    The relay actuater code is working fine with my other LoLon esp8266 board, and I get the node and sensors up fine in the mycontroller server.


  • ADMIN

    @njbuch

    I am pretty sure, other examples are working with that configuration. I just pulled the most recent version of the code, and got a glimpse of the error message:

    You are facing this issue with all ESP8266 boards? Or only with https://www.wemos.cc/product/d1-mini.html
    that too only with recent version? old version works good with https://www.wemos.cc/product/d1-mini.html ?



  • @jkandasa Thanks for getting back to me on this. You are a star!

    I am only facing the issue on the Wemos D1 mini boards. I have not tried other versions of them, but they suit me really well on their form factor and specs for my project.

    Everything is working on my other ESP8266 boards, so far I have only tested the example code from the library though. Will dive into a termometer tonight. :)


  • ADMIN

    @njbuch said:
    I do not have any Wemos D1 mini with me. I am testing only with ESP12E and ESP01. Both works great for me.

    looks like inside Wemos D1 mini has ESP12E module only. Can you give a try with the following board on Arduino IDE for your Wemos D1 mini

    0_1486230335064_upload-0131943d-ae09-4022-bc0b-c046ca48a012



  • I have now tried fiddling with different boards, including the NodeMCU 1.0 module. The error is the same, and the board keeps rebooting.



  • Hi again, tried looking for other solutions, and checked this one: https://github.com/esp8266/Arduino/issues/2414

    This guy is having the same problem, but solved it with using a powered HUB, I tried the MycontrollerDevice with some extra juice, and it did not change a thing.

    :(

    My conclusion is that it writes: "MC[I]: Booting ESP8266 device..." before the exception, there is an illegal pointer operation somewhere in the library....


  • ADMIN

    @njbuch Can you try some simple sketch without MyControllerDevice and what is the status?
    No clue yet :(


  • ADMIN

    @njbuch Are you using Enable auto discovery? If yes, can you disable it and try again? when configuring your device?


Log in to reply